Commencer un nouveau sujet
Répondu

How to switch to new semarchy_repository database?

We have been trying a cloud install whereby we create a new VM using the Semarchy xDM image in azure which creates the xDM application, this installs a default postgres database which is then populated ok.


If I use psql I can see that xDM tables are populated:

sudo -i -u postgres

psql
postgres=# \dt *.*
semarchy_repository | idm_effective_role | table | semarchy_repository
semarchy_repository | idm_idp_test | table | semarchy_repository
semarchy_repository | idm_latest_user_login | table | semarchy_repository


What we could like todo is hook up the xDM application to a different semarchy_repository database and to have the application re-populate

the schemas.


When we switch to a SQL Database, connection/auth have been verified, and then restart tomcat to restart the xDM all seems fine but no tables in the new database.


It is not clear from docs that setting SEMARCHY_SETUP_TOKEN will trigger this and or how SEMARCHY_SETUP_TOKEN should best be setup with the tomcat setup that has been installed.


Interesting that we get NO errors from semarchy and that it seems all is ok but of cause the application is not available from the web. 





Meilleure réponse

Hi Paul,


it seems that you created a ticket for this same question.

I'm writting the conclusion of the ticket in case it helps others:

The  SEMARCHY_SETUP_TOKEN  needed to be set as an environment variable in the setenv.sh, in your case, using


export SEMARCHY_SETUP_TOKEN=<your_token_value>


Because you are running tomcat on a Linux server. The samples to set environment variables were described here in our documentation.


Best regards,

Stéphanie.


1 commentaire

Réponse

Hi Paul,


it seems that you created a ticket for this same question.

I'm writting the conclusion of the ticket in case it helps others:

The  SEMARCHY_SETUP_TOKEN  needed to be set as an environment variable in the setenv.sh, in your case, using


export SEMARCHY_SETUP_TOKEN=<your_token_value>


Because you are running tomcat on a Linux server. The samples to set environment variables were described here in our documentation.


Best regards,

Stéphanie.


Connexion pour poster un commentaire